API Support Forum
OEC API > API Support > Not Able to Build GF api 4.0.3.5
Author Topic: Not Able to Build GF api 4.0.3.5
(5 messages, Page 1 of 1)
Moderators: VPfau
BGoyal9136
Posts: 12
Joined: Sep 21, 2017


Posted: Mar 26, 2020 @ 05:23 AM             Msg. 1 of 5
Hi Team,

I am trying to build GF 4..0.3.5 api version in my c# application. I am using 4.8.03753 .NET framework and Microsoft visual studio version is 16.1.1.

but i am not able to build my project. i am getting build issue in GF api. could you please help me out to solve this.

Thanks
Kapil Goyal
VPfau
Moderator
Posts: 117
Joined: Oct 26, 2011


Posted: Mar 27, 2020 @ 08:44 AM             Msg. 2 of 5
Hello Kapil,

what build issue is?
Vitaliy Pfau
BGoyal9136
Posts: 12
Joined: Sep 21, 2017


Posted: Mar 29, 2020 @ 03:34 AM             Msg. 3 of 5
Hi Team,

while i am building the project i am getting below error :

CS0246 the type or namespace name 'TickReceivedEventArgs' could not be found (are you missing a using directive or an assembly reference?)

But i have already added GF api references in project.could you please let me know what i am missing here.


Thanks
Kapil Goyal
VPfau
Moderator
Posts: 117
Joined: Oct 26, 2011


Posted: Mar 30, 2020 @ 08:23 AM             Msg. 4 of 5
Class TicksReceivedEventArgs is in GF.API assembly.
Documentation for this class: https://gainfutures.com/GFAPI/html/T_GF_Api_Subscriptions_Ticks_TicksReceivedEventArgs.htm

Please take a look basic and advanced examples and their packages/references.
https://bitbucket.org/GainFuturesDev/advancedexample/src/master/
https://bitbucket.org/GainFuturesDev/basicexample/src/master/
Vitaliy Pfau
CMicciche902
Posts: 249
Joined:


Posted: Mar 30, 2020 @ 09:06 AM             Msg. 5 of 5
I see you are using older API version, our latest version is available at https://www.nuget.org/packages/GFAPI/
Chris M